Create a Database & Collect Data

In Table View, you can directly enter data you have collected, import data that you acquire from outside sources like web sites, and have students enter their own data through the use of surveys. Once you have captured the data, you can modify the formatting and even create new data using formulas.

Working in Table View, you'll learn to do the following:

- Create a new database
- Rename a field
- Add a new field
- Add a new record
- Define fields
- Validate data entered into fields
- Enter record details
- Reorder fields
- Change the default icon
- Import a custom icon
- Create a Survey
- Conduct a Survey
- Create an e-Survey
- Publish an e-Survey
- Take an e-Survey
- End an e-Survey
- View e-Survey results
- View the e-Survey Log

Create a new database

In this lesson, you'll create your own simple sleep survey database.

1. Launch the program.
2. From the InspireData Starter screen, click New.

InspireData will open in Table View.

Rename a field

When you create a new table, you will see that fields are named Field 1, Field 2, and so on. You can rename the fields.

1. Click on Field 1 and type Student.
2. Click on Field 2 and type Age.
3. Click on Field 3 and type Gender.

Add a new field

New tables start with three fields, but you can always add more if you need to.

1. On the Toolbar, click the Add Field button
2. Type Hours Sleep to name the new field.
3. Add another new field and name it Wake Process.
Add a new record

More records can be created quickly and easily.

• To create a new record, click the Add Record button on the Toolbar
  -or-
  With your cursor in the last cell of the bottom row, press Tab.

Define fields

Choosing the kind of data you will put into a field allows you to enter data more quickly. Fields can be restricted to numbers only, text and numbers, dates or true/false values.

The type of data used for a field is called the field type.

1. Select the field named Student by clicking on its field heading.
2. On the Toolbar, click the Field Type menu and select Text.
3. Select the next field, Age, by clicking on its field heading.
4. On the Toolbar, click the Field Type menu and select Number.

5. Select the next field, Gender, by clicking on its field heading.
6. On the Toolbar, click the Field Type menu. Select Text because this is also a text field.
7. Select the next field, Hours Sleep, by clicking on its field heading.
8. On the Toolbar, click the Field Type menu and select Number.

Add the following fields by using the Add field button and continue to select the field type for each one of them:

• How Do You Wake Up? (Field type: Text)
• Breakfast (Field type: Text)

Now any data you enter into these fields will be consistent with the field types you selected.

Note: You can edit cell data in either the text entry field on the toolbar or in the cell itself. If you make a mistake while entering text, just select the words you want to change by dragging your cursor over them and then typing your correction.

Validate data entered into fields

You can control the data entered into fields using Validation settings. For example, you can use the Validation option to create a drop-down list of choices, allow numbers only within a certain range or specify the number of characters allowed for a field, as well as other validation choices.
You could, for example, limit the age range for people in the sleep survey to secondary students only.

1. Click on the field heading for **Age**.

2. Click on the Validation... button.
3. A dialog box will appear. Click the radio button next to **In range**.
4. In the **from** field, type 11, and in the **to** field, type 17, then click **OK**.

![Image of validation settings]

Now your Age field will accept only numbers between 11 and 17.

**Enter record details**

Now that your table is set up, you can start entering data.

1. Click in the top left data cell to select it (it will turn orange when selected). Type **A** as an identifier for the first student.
2. Press **Tab** to move to the next cell. Type **14** under **Age**.
3. Tab to the **Gender** field. Type **F**.
4. Tab to the **Hours Sleep** field. Type **9**.
5. Continue to add sample data to the remaining fields and records, using the table below as a guide.

![Image of data table]
Increase text size for elements in Table View

You can increase the size of the text in cells and the notes field, as well as field names, using the text size control in the top toolbar. This is especially useful when you are working in a group around a computer monitor or when using a projector.

1. On the Toolbar, click the Text Size button.
2. Choose which of the three sizes works best to view the table.

Reorder fields

To change the order of the fields in your table click on their field headers and drag them.

- Click on the field heading of the Age field, then drag it to the right of the Gender field.

Watch the carat mark as you drag so you can place the field where you want it. Simply release the mouse button to place it.

Change the default icon

Changing or customizing the icons that appear in your table adds further meaning to your plots. InspireData offers a library of more than 120 icons. Icons selected in Table View will also represent each record when it appears in Plot View.

To change the default icon to a custom icon:

1. Double-click the icon in the top-left comer of the table (the default icon).
   The Icon Editor appears:
2. Select a different icon from the Icon Library or use the paint and draw tools in the Icon Editor to customize your selection.

3. Click OK to make the new icon your default icon for the entire table.
   All of the existing records with the old default icon will be updated, and all new records will use the new default icon.

   **Note:** If you want to return to the original version of the icon, click Revert.

**Import a custom icon**

You can import a photograph or graphic from a drawing program or web browser and use it as an icon. Imported graphics are automatically resized to fit into the space available on the canvas of the Icon Editor.

**To add a custom icon to Student A:**

1. Double-click on **Student A's icon** to open the Icon Editor.
2. Click the **Import** button.
3. Locate and click on the file you want to import. InspireData can import most types of image files, including .GIF and .JPG.
4. Click the **Open** button.
5. Click **OK** on the Icon Editor.

   **Note:** Use the Icon Editor tools to further customize an imported image.
Create a Survey

A Survey allows you to create new records and enter data for those records using an on-screen form, similar to one you might find on a web page. Using the sleep survey as an example, students can answer the questions you have set up for your fields.

The Survey is especially useful when you have a group of people who aren't familiar with InspireData. With a Survey, they can enter data directly into your document.

You can set up a computer as a Survey station and let students take turns filling out the form. When a Survey is completed, its data is added as a record to your database.

1. On the Table menu, select Edit Survey.
2. Click the Use custom title checkbox.
3. Type Student Sleep Survey into the title box.
4. If you want the respondents to have the ability to add their own individual icon, click the Allow user to select record icons checkbox.
5. The Question area of the form is automatically filled out with the field names. If the field name is sufficient for the respondent to answer the question, use the field name. If not, enter a complete question to guide participants in their responses. InspireData allows you to use up to 256 characters for a question.
6. Locate the questions you’d like to make required, then click the Required? checkbox.

When a question is set as required, the words “This value is required” will appear below the question in the Survey. Respondents will not be able to submit their record until this field is filled out.
7. Click OK.

Be sure to launch your survey after you have finished editing it to make sure it appears the way you want it to appear. See Launch a Survey on page 7.

Note: The Invitation text applies to e-Surveys only. To learn more about e-Surveys, see Create an e-Survey on page 8.
Launch a Survey

Once you have your Survey set up the way you like, you can start collecting data.

1. On the Table menu, choose Launch Survey.

2. Ask your participants to come to the computer one at a time.

3. Instruct each participant to fill out the form and click the Add Record button when they are finished.

4. After all of the participants have entered their data, click the Close button.

5. On the File menu, choose Save to save your data.

Create an e-Survey

An e-Survey allows you to collect data by publishing your database to a web site. Respondents need not be in the same location and are able to add responses to your e-Survey as long as they have a connection to the Internet. It is not necessary to have InspireData installed in order to fill out an e-Survey.

Once responses are complete, you can download your database to InspireData and begin analyzing data.

To create an e-Survey:

1. On the Table menu, choose Edit Survey.

2. Click the Invitation text check box at the top of the dialog box.

3. Type an invitation to participate in your e-Survey, such as, “Be sure to fill out my e-Survey on sleep habits for our class!”

4. When your e-Survey has been published to the web and accessed by respondents, the wording you type here will be visible at the top of the web page.

5. Click OK.

Publish an e-Survey

Once your e-Survey has been published, it will be available as a form to fill out on a web site. e-Survey respondents will need to know the web URL and the Survey ID to take your survey. Respondents simply use their web browser to load and fill out the e-Survey.
To publish an e-Survey:
1. From the Table menu, choose Publish e-Survey.
2. When the dialog box appears, click the Publish button.

![Publish e-Survey dialog](image)

When the second dialog box appears, as shown below, you will see both a Survey ID and an Owner ID for your e-Survey:

![Survey ID and Owner ID](image)

Those who participate in your e-Survey will need the Survey ID. To end your e-Survey you must know the Owner ID.

Since this is the only location where the Owner ID is given to you, it is a good idea to print this dialog. To print it, click on the Print This Text button at the bottom of the dialog.

You may also end your e-Survey directly from this dialog by choosing the End e-Survey button. To read more about ending e-Surveys, see End an e-Survey on page 10.

3. Click Done.

**Take an e-Survey**

To take an e-Survey you must have access to the Internet.
To take an e-Survey:

- Navigate to [http://esurvey.inspiredata.com](http://esurvey.inspiredata.com) using your web browser, then enter your Survey ID and click Start.

When you click start, your e-Survey opens, as shown:

Once you have filled out the survey, click Submit to save the data. All participants who fill out the e-Survey and click Submit will have their records added to your database.
End an e-Survey

You can end an e-Survey immediately after it is created by clicking End e-Survey in the same dialog you use to create one, as shown:

If you end it before data has been entered, no entry will appear in the e-Survey log. See View the e-Survey Log on page 12 for more information.

If you have received all the data you need and want to stop accepting contributions to your e-Survey, you must end it from the File menu.

To end an e-Survey:

1. From the File menu, choose End e-Survey...
2. Enter the Owner ID for the e-Survey you want to end (you were provided with the Owner ID when you originally set up your e-Survey).
3. Click on the End e-Survey button.
4. When asked to confirm, choose Yes to end the e-Survey.

After the survey has ended, no one will be able to add data to the e-Survey even if they know the Survey ID. However, the database will still be available to download from the InspireData Starter screen using the e-Survey button.

Note: e-Survey databases can still be downloaded even after the e-Survey has ended and will remain available for a period of time determined by Inspiration Software ®.

View e-Survey results

The results of an e-Survey can be viewed at any time by opening the database with InspireData. Once data has been downloaded, it is contained in a new database, which can be modified in any way and saved. You can do this even when participants are still adding records to your e-Survey.

Each time you or anyone else downloads the data, a new InspireData file is created. Plots and slides present in the database at the time it was published will also be available, in addition to eSurvey records.

When you no longer want contributions to the database, you can end your e-Survey.

To view results of an e-Survey:

1. On the InspireData Starter screen, click on the e-Survey button.
2. Enter the Survey ID.

To bring your e-Survey to a close, see End an e-Survey on page 10.

View the e-Survey Log

Every time an e-Survey is published, it is recorded in the e-Survey log. This log is associated with the user currently logged on to the computer. The log contains the date the e-Survey was published, the database name and the Survey ID.

• From the File menu, choose View e-Survey Log...

The most recent surveys are listed first.

Source: InspireData Users Manual©, Chapter 2